Author Topic: Problem with mount button  (Read 331 times)

Dave Burton

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Problem with mount button
« on: April 21, 2021, 01:51:33 PM »
Hiya, this has been a long term niggle, but when you have favourite mounts set and manually go into the mounts page and mount something that's NOT a favourite, the mounts button will then only show the "mount random" button. The only way to get the favourites back is a complete log out and back in, a /reload will not fix it.

Thanks :)

MuffinManKen

  • Administrator
  • Sr. Member
  • *****
  • Posts: 419
  • Karma: +12/-0
    • View Profile
Re: Problem with mount button
« Reply #1 on: April 21, 2021, 04:36:19 PM »
That's very odd. I will look into it.

MuffinManKen

  • Administrator
  • Sr. Member
  • *****
  • Posts: 419
  • Karma: +12/-0
    • View Profile
Re: Problem with mount button
« Reply #2 on: April 22, 2021, 12:44:42 PM »
I'm trying to reproduce this, but it's not happening.

I have the Mount button Enabled. "Rearrange Order on Use" is checked.  "Show Favourites" is checked.

The mount button is showing my list of Favourites and the "Summon Favourite Mount" button.

I'm not mounted.  I then open the Mounts window and scroll down to a mount that is not one of my favourites.  That mount is summoned.  Hovering over the Mount button on the Autobar bar, I still see my list of Favourites and the "Summon Favourite Mount" button.

Any feedback on what you're doing differently would be helpful; it's hard to fix something that I can't see.

Boven

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Problem with mount button
« Reply #3 on: April 29, 2021, 06:34:05 PM »
I've noticed this for a long time.  I think it has to do with mounts that aren't in Autobar's library.  The Corridor Creeper, for example.  If I mount it in the Maw, quite often Autobar will only display the random mount button and not my favorite mounts.  While it's anecdotal, the favorites *seem* to disappear from Autobar when entering no-mount zones or taking portals or entering instances.

When it does happen, opening the mounts window in WoW, selecting a favorite and 'manually' mounting tends to restore the favorites to autobar.

jrnhtown04

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Problem with mount button
« Reply #4 on: April 29, 2021, 09:43:45 PM »
Just as Burton has described, I too have this issue at times.  I also notice it a cure after looking through and summoning a "non-favourite" mount.

My options are the same as MuffinMan's.

Thank you MuffinManKen for your work.  8)