Recent Posts

Pages: [1] 2 3 ... 10
1
AutoBar / Re: Moving buttons
« Last post by MuffinManKen on November 04, 2021, 04:38:53 PM »
What version are you using?
2
AutoBar / Moving buttons
« Last post by Boven on October 29, 2021, 01:03:19 PM »
I know Autobar is no longer being supported, but I'm hoping someone here will have some advice.

Somehow the mount button on my main bar got moved to the far right position.  I can't seem to get it back to where it used to be.  When I use the "Move the Buttons" in config, I'm getting a lua error:

Message: Interface\AddOns\AutoBar\Core.lua:856: attempt to call method 'MoveButtonsModeOn' (a nil value)
Time: Fri Oct 29 13:00:01 2021
Count: 1
Stack: Interface\AddOns\AutoBar\Core.lua:856: attempt to call method 'MoveButtonsModeOn' (a nil value)
[string "@Interface\AddOns\AutoBar\Core.lua"]:856: in function <Interface\AddOns\AutoBar\Core.lua:852>
[string "=[C]"]: ?
[string "@Interface\AddOns\Ace3\AceConfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua"]:51: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:49>
[string "@Interface\AddOns\Ace3\AceConfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua"]:847: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:668>
[string "=[C]"]: ?
[string "@Interface\AddOns\Ace3\AceGUI-3.0\AceGUI-3.0.lua"]:72: in function <Interface\AddOns\Ace3\AceGUI-3.0\AceGUI-3.0.lua:70>
[string "@Interface\AddOns\Ace3\AceGUI-3.0\AceGUI-3.0.lua"]:306: in function `Fire'
[string "@Interface\AddOns\Ace3\AceGUI-3.0\widgets\AceGUIWidget-Button.lua"]:22: in function <...dOns\Ace3\AceGUI-3.0\widgets\AceGUIWidget-Button.lua:19>

Locals: <none>

I've tried totally removing Autobar and all it's saved files and downloading both the current and previous versions to start fresh, but I still get the same error.
3
AutoBar / Re: tbc mana/health potion injectors not listed
« Last post by FlyPaper on September 18, 2021, 06:35:15 PM »
Adding items is usually an easy fix, just have to find the related lists in the lua code and find the itemID for said items(which is the number in wowheads URL for the item in question), then copy the code for other items that are already listed and change the relevant parts to the new itemID/name and place the new line in the same list.  Now this is just based off of what I've done before with mage portals so it might not be exactly the same. I've done it before for mage portals. That said, I don't play classic so I can't really help here.

This is an example I used in the past, I'm assuming it'll be similar for potions/lock stones:

In the AutoBarCatagory lua add, in the "Spell.Portals" section:
      "MAGE", ABGCS:GetSpellNameByName("Teleport: Dazar'alor"), ABGCS:GetSpellNameByName("Portal: Dazar'alor"),
      "MAGE", ABGCS:GetSpellNameByName("Teleport: Boralus"), ABGCS:GetSpellNameByName("Portal: Boralus"),

Then, in the CachedSpellData lua add:
               ABGCS:CacheSpellData(281402, "Portal: Dazar'alor");
               ABGCS:CacheSpellData(281404, "Teleport: Dazar'alor");
               ABGCS:CacheSpellData(281400, "Portal: Boralus");
               ABGCS:CacheSpellData(281403, "Teleport: Boralus");
4
AutoBar / Re: AutoBar Classic - Report Missing Class Abilities & Items Here
« Last post by Firehex1 on September 16, 2021, 02:43:40 PM »
I started to play paladin and found 4 bugs:

1. Blessing of kings with left and right mouse clicks casts only group version. Need single version (20217)
2. No group version for Blessing of Might (25782, 25916, 27141)
3. Missing both version Blessing of Sanctuary (20911, 25899)
4. Divine intervation missiong (19752). I think should be added in same button with Divine shield
5
AutoBar / tbc mana/health potion injectors not listed
« Last post by derpboy03 on September 10, 2021, 05:08:18 PM »
in tbc they are just another kind of mana/healing pot that stacks to 20

if anyone decides to take over here is one thing to fix.
6
AutoBar / Re: Hearth items missing
« Last post by brykrys on September 08, 2021, 05:14:37 PM »
I had this issue after updating to 9.1.0.02, the Toy Heathstones were missing the majority of the time, and a /reload did not always get them to appear.

Reverting to 9.0.5.01 (*) the Toy Hearthstones do work as before, indicating that some change in 9.1.0.02 has caused this issue.

Will stick with 9.0.5.01 for now, but will see if some of the datafiles from 9.1.0.02 can be dropped in, or otherwise if I can edit the datafiles to include some missing items.

(*) Reverting to 9.0.5.01 after updating to 9.1.0.02 will cause an error on login. Reverting to a backup save file from before the update fixes the error; if you do not have an earlier backup you may need to delete the save file and redo your layout.
7
AutoBar / Re: Hearth items missing
« Last post by Onur Malkoc on August 28, 2021, 01:14:39 PM »
I'm experiencing the same thing :D But i don't want toy hearthstones showing so it starts fine then after logging with other chars they start showing even if i turned off "show favorite toy" from bar and/or button options.
8
AutoBar / Re: Hearth items missing
« Last post by FlyPaper on August 26, 2021, 01:21:49 AM »
I've noticed that too, it only happens with the initial load for me, if I /reload once I'm in game the hearth toys will reappear.  Not too helpful, btu it's a workaround of sorts until someone with addon knowledge can fix it.
9
AutoBar / Hearth items missing
« Last post by dbroy on August 25, 2021, 03:55:26 PM »
Hi there -

I noticed my toy hearthstones are missing in the latest update. Is this a change or a bug? Is there something I can do to remedy it locally?

Thank you!
10
AutoBar / Re: Will autobar be updated by someone going forward?
« Last post by Waste on August 24, 2021, 09:10:53 PM »
when are you going to stop maintaining this?
Pages: [1] 2 3 ... 10